
Exercício 4 

Neste exercício pede-se determinar quais estações de trem estão a até uma certa distância de 

alguma estação de metro. Também será solicitado agregar espacialmente os distritos de cada 

município, de forma a se ter uma camada de municípios. 

Serão u"lizados neste exercício o projeto AUT5826 - Exercicio 1.qgz e o GeoPackage 

Exercicio_1.gpkq, dos primeiros dois exercícios. Pode-se compactar esses arquivos num único 

arquivo formato zip, com o uso do Windows ou de so,ware específico, como backup, antes de 

prosseguir. 

Parte I – estações de trem a até uma certa distância de alguma estação de metro 

Planejamento (1) 

A análise dos dados das camadas estacao_metro e estacao_trem revela algumas dificuldades: 

(i) as camadas não contêm propriamente estações, mas pares estação-linha; 

(ii) há variações de nome em algumas estações, ou seja, sinônimos, por exemplo: 

a. nomes hifenizados com / sem separação adicional de caracteres em branco 

‘PALMEIRAS-BARRA FUNDA’ * 

‘PALMEIRAS - BARRA FUNDA’ ** 

b. uso de extensões (aos nomes) para diferenciar estações próximas, de mesmo 

nome 

‘LAPA (LINHA 7)’ ** e ‘LAPA (LINHA 8)’ ** 

‘SANTO AMARO’ * e ‘SANTO AMARO (LINHA 9)’ ** 

* camada estacao_metro 

** camada estacao_trem 

Dada a complexidade do problema, deve se planejar os procedimentos a serem adotados. Para 

tanto, foi elaborado um diagrama operacional simplificado, que omite os detalhes do ambiente 

de banco de dados. Os diagramas das figuras 1 a 3, descri"vos, do procedimento, foram 

revisados duas vezes. Melhor planejar do que executar com erro, por duas vezes. 

Foi elaborado uma tabela, MLS, a ser periodicamente atualizada, de modo a corrigir o 

problema (ii) dos sinônimos, ou seja, das diferentes versões de nome. A tabela MLS, também 

acrescenta: 

 a ordem de cada estação servida por uma linha (ou serviço), segundo uma de suas 

direções; 

 a data de início de operação do par estação-linha. 

Em ambos os casos, estacao_metro e estacao_trem, aproveitam-se apenas as coordenadas dos 

pontos que representa o par estação-linha, sendo os demais atributos provenientes da tabela 

MLS. 

A tabela MLS busca espelhar os elementos das camadas disponibilizadas no sí"o eletrônico do 

GeoSampa. Os atributos de ligação na tabela MLS, dos pares estação-linha, são 

respec"vamente NOMEGS e LINE. Seus correspondentes nas camadas do GeoSampa são, 

respec"vamente, nm_estacao e cd_iden"1. 



Figura 1 – padronização e discriminação dos pares estação-linha de metro 

 

Figura 2 – padronização e discriminação dos pares estação-linha de trem 
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Figura 3 – processamento para a solução do problema proposto 

 

Uma vez feitas as correções, para a solução da questão (ii) acima descrita, procede-se à solução 

do problema proposto, conforme indicado na Figura 3. 

Cria-se um buffer de 1000 m (ou 1 km) em torno dos pontos que representam cada estação de 

metro. Neste caso, pede-se gerar um buffer, independente, para cada estação, com a cópia dos 

atributos (e de seus valores) de estacao_metro para os correspondentes elementos na camada 

de buffer. 

Faz-se a interseção espacial entre a camada dos buffers, em torno das estações de metro e os 

pontos que representam as estações de trem, sem, no entanto, gerar as figuras geométricas 

resultantes dessas interseções. Apenas os dados alfanuméricos da interseção interessam para a 

solução do problema. 

Eliminam-se os pares estação-linha nos casos em que uma estação de trem é a mesma para 

alguma linha do metro, ou seja, quando de tratar da mesma estação servindo uma (ou mais 

linhas de trem) e também uma ou mais linhas de metro. Esta operação resolve a questão (i), 

indicada no início desta parte. 
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Em seguida, eliminam-se as duplicidades de ocorrência de uma estação de trem, ou seja, no 

caso dela estar a até 1 km de mais de uma estação de metro, no que seria listada mais de uma 

vez. Por fim, exporta-se a lista em formato csv. 

Execução 

(2) 

Baixar o arquivo MLS.zip, que contém MLS.xslx, com a tabela a ser usada na correção dos 

arquivos estacao_metro e estacao_trem. Lembrar de descompactar o arquivo. 

(3) 

Carregar a tabela MLS.xslx no GeoPackage 

 Database > DB Manager > GeoPackage > � Exercicio_1.gpkg 

 Import Layer/File... 

  Input File [...] 

   navegar até a pasta de trabalho e selecionar o arquivo MLS.xslx 

  Output table 

   Table MLS 

 [OK] 

(3.1) 

Verificar na tabela de atributos, se a operação foi bem sucedida. 

(4) 

Correção da camada estacao_metro 

Database > DB Manager > GeoPackage > � Exercicio_1.gpkg 

[SQL Window] ou Database > SQL Window 

 [SQL] 

 � Tables 

  estacao_metro 

  MLS 

 que, ao final, deve exibir 

  "estacao_metro", "MLS" 



 clicar na caixa de texto Where 

 � Columns 

  "estacao_metro"."nm_estacao" 

 digitar na caixa de texto 

  = 

 � Columns 

  "MLS"."NOMEGS" 

 � Operators 

  AND 

 � Columns 

  "estacao_metro"."cd_iden"1" 

 digitar na caixa de texto 

  = 

 � Columns 

  "MLS"."LINE" 

 que, ao final, deve exibir 

  "estacao_metro"."nm_estacao" = "MLS"."NOMEGS" AND 

"estacao_metro"."cd_iden"1" = "MLS"."LINE" 

 

 clicar na caixa de texto Columns 

 � Columns 

  "estacao_metro"."geom" 

  “MLS”.* 

 que, ao final, deve exibir 

  "estacao_metro"."geom", 

  "MLS".* 

 clicar na caixa de texto Order By 

 � Columns 

  "MLS"."LINE" 

  "MLS"."SEQUENCE" 

 

Na tela do SQL Window salvar a query, em sua pasta de trabalho, como 

 q_corrige_estacao_metro 

  [v] Load as new layer 

  [v] Geometry column geom 

  Layer name (prefix) estacao_metro_corrigida 

 [Execute] e [Load] 

(5) 

Carregar os dados no GeoPackage. 

Resulta erro de duplicidade do “MLS”.”fid” da tabela MLS (?) 

A estação Vila Mariana está duplicada (!) no arquivo ob"do do sí"o eletrônico de GeoSampa, 

usado nos exercícios até este ponto. Neste caso, há de se refazer a query acima para, também, 

eliminar a duplicata, conforme indicado a seguir. 



(6) 

Database > DB Manager > GeoPackage > � Exercicio_1.gpkg 

 SQL Window 

 [SQL] 

 Proceder como anteriormente, exceto nos conteúdos das caixas de texto Columns e 

Group By, cujas expressões devem, ambas, ficarem como segue. 

 "estacao_metro"."geom", 

 "MLS"."CODE", 

 "MLS"."NOME", 

 "MLS"."NAME", 

 "MLS"."LINE", 

 "MLS"."EXTENSION", 

 "MLS"."SEQUENCE", 

 "MLS"."SINCE" 

e/ou 

 "estacao_metro"."geom", "MLS"."CODE", "MLS"."NOME", "MLS"."NAME", 

"MLS"."LINE", "MLS"."EXTENSION", "MLS"."SEQUENCE", "MLS"."SINCE" 

De volta à Janela SQL Window, a expressão resulta algo como: 

SELECT "estacao_metro"."geom", 

 "MLS"."CODE", 

 "MLS"."NOME", 

 "MLS"."NAME", 

 "MLS"."LINE", 

 "MLS"."EXTENSION", 

 "MLS"."SEQUENCE", 

 "MLS"."SINCE" 

 FROM "estacao_metro", "MLS" 

 WHERE "estacao_metro"."nm_estacao" = "MLS"."NOMEGS" AND 

"estacao_metro"."cd_iden"1" ="MLS"."LINE" 

 GROUP BY "estacao_metro"."geom", "MLS"."CODE", "MLS"."NOME", "MLS"."NAME", 

"MLS"."LINE", "MLS"."EXTENSION", "MLS"."SEQUENCE", "MLS"."SINCE" 

 ORDER BY "MLS"."LINE", "MLS"."SEQUENCE" 

Salvar a query sobrescrevendo a anterior na pasta de trabalho, e executar novamente. 

 Layer Name (prefix): 

  q_corrige_estacao_metro 

 [v] Load as new layer 

 [v] Geometry column geom 

 Layer name (prefix) estacao_metro_corrigida 

 [Execute] e [Load] 

(7) 

Remover a camada virtual e salvar o projeto. 



(8) 

Repe"r o processo para a camada estacao_trem, para criar a query q_corrige_estacao_trem e 

a camada estacao_trem_corrigida no GeoPackage. 

(9) 

Após a conclusão do processo, pode-se verificar, da análise das tabelas MLS, e informações, do 

cadastro das estações de trem do GeoSampa, confrontadas com informações dos sí"os 

eletrônicos do Metrô, CPTM, e Wikipedia, indica haver erros e omissões, indicadas nos quadros 

1 e 2. 

Quadro 1 - Estações não alocadas a linhas nos arquivos do GeoSampa 

Estação ausente nas linhas 

Brás    11 12 

Calmon Viana 
Engenheiro Goulart 
Tatuapé 

    12 

Luz   10 11  

Osasco 
Presidente Al"no 

 9    

Palmeiras – Barra Funda 7  10 11  

 

Quadro 2 – Outros erros e omissões nos arquivos do GeoSampa 

A estação Água Branca está cadastrada como pertencente à linha 8, quando o correto 
seria a linha 7 

Falta a estação Varginha (linha 9) 

Falta o serviço expresso ao Aeroporto Internacional André Franco Montoro, em 
Guarulhos, a par"r da estação Palmeiras – Barra Funda, passando pelas estações Luz, 
Brás e Guarulhos-CECAP 

 

(10) 

Buffer de 1000 m em torno dos pontos que representam as estações de metro. 

Vector > Geoprocessing Tools > Buffer... 

 Input layer estacao_metro_corrigida  [EPSG: 31983] 

 Distance 1000 meters 

 [   ] Dissolve Result – não marcar para copiar os dados da estação correspondente 

 Buffered [...] Save to geoPackage... 

  output  metro_buffer_1000 

 [Run] 

(10.1) 

reordenar a exibição das camadas, de modo a que os buffers fiquem sob as estações 

(11) 

Buffer de 10 m em torno dos pontos que representam as estações de trem* 



Vector > Geoprocessing Tools > Buffer... 

 Input layer estacao_trem_corrigida  [EPSG: 31983] 

 Distance 10 meters 

 [   ] Dissolve Result – não marcar para copiar os dados da estação correspondente 

 Buffered [...] Save to geoPackage... 

  output  trem_buffer_10 

 [Run] 

* Não se aceita interseção com representações do "po ponto, algo que não havia sido previsto, 

quando da etapa de planejamento (ver Figura 3 e texto correspondente). 

 

(12) 

Interseção das camadas 

Vector > Geoprocessing Tools > Intersec"on... 

 Input Layer trem_buffer_10 [EPSG: 31983] 

 Overlay Layer metro_buffer_1000 [EPSG: 31983]  

 Input fields to keep […] 

  [v] CODE 

  [v] NAME 

  [v] LINE 

  [OK] 

 Overlay fields to keep […] os mesmos acima 

 Advanced Parameters 

  Overlay fieds prefix m_ 

 Intersec"on […] 

  salvar no GeoPackage como trem_intersect_metro_1000 

 [v] Open output file a,er running algorithm 

[RUN] 

Visualizar o resultado e salvar o projeto. 

(13) 

Eliminar eventuais redundâncias, ou seja, uma estação de trem ter mais de uma interseção 

com estações de metro. 

Database > DB Manager > SQL Window 

   [SQL] – montar a expressão abaixo: 

 SELECT "trem_intersect_metro_1000"."CODE", 

  "trem_intersect_metro_1000"."NAME" 

 WHERE "trem_intersect_metro_1000"."CODE" <> 

  "trem_intersect_metro_1000"."m_CODE" 

 FROM "trem_intersect_metro_1000" 

 GROUP BY "trem_intersect_metro_1000"."CODE", 

  "trem_intersect_metro_1000"."NAME" 

 [v] load as new layer 

 [  ] Geometry column – desnecessário (deseja-se apenas a lista) 

 Layer name (prefix) estacao_trem_ate_1km_estacao_metro 



[Execute] e [Load] 

Obs: a operação acima é mais simples do que havia sido planejado inicialmente (ver a 

Figura 3), mas o resultado prá"co é o mesmo. 

Para efeito de documentação do realizado, o diagrama da Figura 3 pode ser alterado para 

refle"r o que, de fato, foi feito, conforme indicado na Figura 4. 

Figura 4 – processamento para a solução do problema proposto - atualizado 

 

(14) 

Exportar o resultado como arquivo formato csv, que possa ser aberto diretamente em uma 

planilha eletrônica. 

Parte II – criar polígonos representa>vos dos municípios da RMSP, a par>r de seus distritos 

É certo que estejam disponíveis diversos mapas digitais dos municípios da RMSP. Entretanto, 

dada suas diferenças de origem, dificilmente os vér"ces de seus polígonos de representação 

coincidem com os dos distritos fronteiriços de cada município, do mapa de distritos objeto dos 

exercícios anteriores. 
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Propõe-se dissolver os limites dos distritos internos a cada município de modo que os vér"ces 

desses municípios coincidam em número e coordenadas com vér"ces de seus distritos 

limítrofes. Isso tendo por pressuposto, que o original tenha sido elaborado com a qualidade 

necessária, ou seja, que os vér"ces dos distritos confrontantes coincidam em número e 

coordenadas, em suas adjacências. É comum haver cadastros, produzidos sem esse cuidado, 

por exemplo os polígonos dos setores censitários do IBGE nos censos passados. 

(15) 

Verificar a consistência geométrica do mapa de distritos em: 

 Vector > Geometry Tools > Check Validity… 

  Input layer: DistritosCEM [EPSG 31983] 

  [ Run ] 

  que neste caso, não aponta haver erros 

São criadas três camadas temporárias, se isso es"ver indicado na tela de execução do teste. 

Uma apresenta a geometria que passou no teste, a outra a geometria inválida e dos vér"ces 

correspondentes aos erros. Após verificar não haver erros, essas camadas podem ser 

removidas do projeto. 

(16) 

Dissolver os distritos para formar seus correspondentes municípios 

 Vector > Geoprocessing Tools > Dissolve... 

  Input Layer: DistritosCEM [EPSG 31983] 

  Dissolve Fields […] 

   [v] MUNSIGLA 

   [v] MUNNOME 

   demais desmarcados 

  Advanced Parameters 

   [  ] keep disjoint features separate** 

  Dissolved […] 

   Save to Geopackage 

    Exercicio_1.gpkg 

    Layer name: MunicipiosCEM 

  [v] Open output file a,er running algorithm 

  [Run] 

  [Close] 

** não faz diferença, neste caso, pois os territórios de todos os municípios conhguos. Caso não 

fossem, por default (opção desmarcada), seriam formados mul"polígonos. 

(17) 

A ferramenta parece ser um tanto limitada, ao menos até a versão 3.28 (Firenze) usada na 

elaboração do exercício. Ela não provê opções de agregação de atributos que não os usados 

para a dissolução dos distritos. Esses atributos, no entanto, não foram eliminados e estão com 

os valores de um dos distritos de cada município. 

Pode-se neste caso fazer as seguintes correções: 

• IBGECOD preservar os primeiros sete caracteres, eliminando os dois úl"mos 

• SIGLA, NOME, NOMECAPS, com_metro e com_trem eliminar da tabela 



Abrir a tabela de atributos, entrar em modo edição, remover os atributos acima indicados e 

proceder a alteração do IBGECOD, conforme segue. 

[Field Calculator] 

 [v] Update exis"ng field 

  IBGECOD 

 � String 

  le, 

 � Fields and Values 

  IBGECOD 

 na caixa de texto Expression 

  completar, digitando: virgula, 7 e fechar os parênteses. 

  le,( “IBGECOD” , 7) 

 verificar no Preview se a operação está correta 

 [OK] – para executar 

Salvar as alterações, e sair do modo de edição. 

Na lista de camadas, reordenar de modo que os municípios fiquem sob os distritos, e salvar o 

projeto. 

(18) 
Uma alterna"va, ú"l no caso da necessidade de se agregar atributos, por exemplo, pela soma 
dos valores das feições componentes, pode ser executada, a par"r do Processing Toolbox: 
 Vector Geometry 
  Aggregate 

Parte III – Segundo Exercício para Avaliação 

Pede-se, a exemplo dos exercícios anteriores: 

(A.2.1) Produzir contagem de estações metroferroviárias por distrito - não contar pares 
estação-linha, apenas as estações. 

(A.2.2) Para os distritos que não possuem estações metroferroviárias em seus territórios, 
indicar quais tem, ao menos uma, estação a até 200 metros de seus limites. 

Em cada caso, indicar, considerando o GeoPackage no estado correspondente, ao menos, ao 
final da Parte I deste Exercício 4, entregar: 

(a) Diagrama operacional do processo (elaborar antes de executar as operações no so,ware 
SIG escolhido*); 

(b) Roteiro detalhado de todo o procedimento, que permita outra pessoa executá-lo, no 
so,ware SIG indicado*; 

(c) Listas geradas em formato CSV, que possam ser carregadas diretamente por so,ware de 
planilha eletrônica. 

* Pode ser usado outro so,ware SIG que não o QGis, como, por exemplo, ArcGis, TerraView, 
MapInfo, etc., desde que se consiga usar o GeoPackage criado e usado nos exercícios 
anteriores. 


